Back to Referenda
Polkadot Runtime Upgrade to v0.9.28
9d ago
0 Comments
Executed

The proposal proposes an upgrade of the Polkadot Runtime to v9280 - Release notes, runtime changes and proposal hash can be found HERE. Feel free to use srtool yourself to check the proposal hash. Among other changes, this release most notably adds nomination pools to the Polkadot runtime - please note that these will need to be configured via governance after enactment of this runtime upgrade.

Runtime

✅ audited #11918 Low - Make new storage layer truly default

✅ trivial #11690 Low - Add event to pallet asset-tx-payment

✅ audited #11796 Low - Auto-incremental collectionid

✅ trivial #11985 Low - Pallet-contracts: fix 16bit func_id

✅ trivial #11991 Low - Contracts: apply depth limit when decoding

⏳ pending non-critical audit #11819 ❗️ Medium - Transaction payment runtime api: query call info and fee details

✅ audited #11927 Low - Transactional: wrap pallet::calls directly in storage layers

✅ trivial #5582 Low - Add nomination pools to polkadot runtime

✅ trivial #5910 Low - Update weights

If passed by the Council, this proposal should be voted by the community for final decision and enacted after. Make sure to vote at your convenience!

Polkassembly
Reply
Up
Share
Votes
AyePassing thresholdNay
50%50%
Aye
0 DOT
Nay
0 DOT
Turnout
0 DOT
Electorate
0 DOT
Passed
Check all votes
Metadata
Proposer
Hash
Delay
02022-09-26 12:22:30
End
02022-09-26 11:42:30
Threshold
Call
Table
callIndex0x0003
sectionsystem
methodsetCode
args
Large data, please check it on subscan
TimelineLatest activity 9d ago
2022-09-19 11:34:06
Started
referendumIndex
75
voteThreshold
SimpleMajority
2022-09-26 11:42:30
Passed
referendumIndex
75
2022-09-26 12:22:30
Executed
result
ok
Comments
SubSquare
Polkassembly
There are no comments here